<2

~PASS
SQLSATURDAY

VIRTUAL

1000
Oregon

melissa ) RedHat B wicrosoftAzre  FYARQUAM O Google Cloud






HAV=NS

CONSULTING

Microsoft” , : :
A  Enhancing User Experiences With

Professional

Advanced Reporting Features






v

Empowerment Through Business Intelligence

b 4 v

* Reid Havens
= Founder | Bl Evangelist | Consultant
= Microsoft MVP
* PBI User Group Co-Organizer — Redmond, WA
= Nickname: “The Viz Wiz"

= Specializes in teaching, consulting, and design

Microsoft®

: - Most Valuable
https://www.havensconsulting.net Professional

reid@havensconsulting.net







||._£| Enhancing User Experiences With
Advanced Reporting Features

Understanding Bookmark Capture States
Configuring and Formatting Buttons
Applying Measure Based Formatting
Implementing Report Tooltips






||._£| Enhancing User Experiences With
Advanced Reporting Features

Understanding Bookmark Capture States
Configuring and Formatting Buttons
Applying Measure Based Formatting
Implementing Report Tooltips






Understanding Bookmarks

Bookmarks Introduction

« Bookmarks capture the currently configured view
of a report page at design-time

« Common uses include:
« Map multiple filter selections for quick navigation
« Dynamically change page visuals and objects
* Assign bookmarks to buttons and/or images

» Report users can open the Bookmarks pane at
view-time

Bookmarks

[1 Add [p View

Clear Filters
“~ Page 1
Nav to P1
P1 Slicers Hidden
P1 Slicers Showing
v Page 2
~ Page 3

N Page 4






Understanding Bookmarks

Bookmarks = Capture States

- Bookmarks save the following elements:

Bookmarks
» Current page
* Filters [1Add [} View
» Slicers (including slicer type) Clear Filters
» Visual selection state (cross-highlight and cross-filter) A Page 1
 Sort order Nav to P1
* Drill location P1 Slicers Hidden
* Object visibility (observed in the Selections pane) P1 Slicers Showing
* Spotlight applied to an object \ Page 2
* Focus applied to an object \/ Page3

N Page 4






Understanding Bookmarks

Bookmarks = Settings

» State capture can include/exclude:

Bookmarks ~ - Data: Filters and slicers
[1Add  [b View » Display: Visibility, spotlight, focus
Clear Fifte  Current page: Current page
~ Page Rename
Nav t Delete
P1 Sli Ungroup
P1 Sl Data A
' Page : Display > States
N Current page B

' Page ¢ All visuals



Selected visuals



Understanding Bookmarks

Bookmarks = Settings

» State capture can include/exclude:

Bookmarks ~ » Data: Filters and slicers
[1Add  [b View » Display: Visibility, spotlight, focus
Clear Fifte  Current page: Current page
™ Pagel  pename » State capture can apply to:
Navt  Delete « All visuals
B Ungroup » Selected visuals
P1 Sli Data
“ Page : Display
~ Page: Current page

' Page ¢ All visuals 1 Visual



Selected visuals I selection



Understanding Bookmarks

Bookmarks = Settings

» State capture can include/exclude:

Bookmark X . :
cokmarks » Data: Filters and slicers
[1Add  [b View » Display: Visibility, spotlight, focus
Clear Filte ——  Current page: Current page
pdate —
™ Page ! paname » State capture can apply to:
Navt  Delete  All visuals
B Ungroup  Selected visuals
P1 Sli Data
... - » Select Update to re-capture state
" Page 2 Isplay
' Page: Current page

' Page ¢ All visuals



Selected visuals



Understanding Bookmarks

Bookmarks = Settings

» State capture can include/exclude:

Bookmark X . .
ooKmarts - Data: Filters and slicers

[1Add  [b View » Display: Visibility, spotlight, focus
Clear Filters » Current page: Current page
~ Page N « State capture can apply to:

Nav to P1 - T

o = Paga Grotp All V|suals.

P1 Slicers Hidden i Selected V|Sua|S

P1 Slicers Showing
" s = » Select Update to re-capture state
o G « Bookmarks can also be organized by

v Page 4 named Groups






Understanding Bookmarks

Bookmarks » Selection Pane

» The Selection pane is a list all objects on a ColeeHon X
report page — configurations include:
. Order Of ObjECtS Layer order Tab order
y Show Hide

* Visibility of objects

« Common uses include:

» Order visuals so visual headers and other visual
pop-ups don't display behind other visuals

» Toggle object visibility to use with bookmarks .
. . age VIEWs
» Report users can open the pane at view-time Unique Page Views

Visible ey HC Logo

Last Refresh Date
Report Title

Page Views Sparkline

Hidden el Monthly Average Daily ..

It is a recommended practice to

o

o

5 9 9

%)

7



give each object a unique name Unique Page Views Spa... @



Understanding Bookmarks

Bookmarks » Selection Pane » Groups

» Objects in the selection pane can also be grouped  scicction X
* Grouped ObjeCtS: Layer order Tab order
 Behave similarly to groups in other Microsoft |
. . y Show Hide
Office tools (e.g. PowerPoint)
» Can be moved together as a single unit Group = °
- Have background color and transparency S oo
Settings objects Last Refresh Date °
. c . b Report Title C
ommqn uses' . ] Page Views Sparkline Ch
« Group similar objects together for easier moving or i -
Copying_and_paSting Unique Page Views ‘o0

e Nrannizinn the celartinn Nana



\le“llthtlly LT I e et | ' Y wl W’ 1 rl\-ﬂl L

Monthly Average Daily ... @



%E Demonstration
One

Understanding Bookmarks

» Exercise 1 — Utilizing the Data Capture State
* Exercise 2 — Utlilizing the Display Capture State
» Exercise 3 — Discussing the Current Page Capture State












References

* What are Bookmarks?
* https://docs.microsoft.com/power-bi/consumer/

» Create Bookmarks to Share Insights and Tell Stories
* https.//docs.microsoft.com/power-bi/create-reports/desktop-bookmarks

« HC Video Playlist — Bookmarks

e https://www.youtube.com/playlist?list=PLzZN99cpDw60AISEZU77Dhcrs6rOgU -
uuz
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Configuring and Formatting Buttons

Button Introduction

« Buttons add functionality to reports that behave similar to
apps — allowing users to hover, click, interact with objects

 Four button states can be individually formatted to create a
rich user expertence:
* Idle — State when inactive - Selected — State during mouse click
« Hover — State during mouse - Disabled — State for page or

hover drillthrough navigation
» Assignable actions include:
* Back’ * Web URL
* Bookmark  Page navigation 1: Navigates back to the

<— Left arrow

—7 Right arrow



* Q&A . Dl’i”thl’OUQh navigation previ6u5 report page Blank



%E Demonstration
One

Configuring and Formatting Buttons

* Exercise 1 — Creating Interactive Buttons

* Exercise 2 — Assigning Page Navigation Actions

» Exercise 3 — Assigning Drillthrough Navigation Actions
* Exercise 4 — Applying Images to Buttons












References

» Use Buttons in Power Bl
* https://docs.microsoft.com/power-bi/create-reports/desktop-buttons

» Create a Drillthrough Button in Power Bl

* https://docs.microsoft.com/power-bi/create-reports/desktop-drill-through-
buttons

» HC Video Playlist — Bookmarks

e https.//www.youtube.com/playlist?list=PLzZN99cpDw60AISEZU77Dhcrs6rOgU -
Uuuz

» HC Video Playlist — Buttons
e https.//www.youtube.com/playlist?list=PLzZN99cpDw60Di-pDQnieuRXHILNFK-







||._£| Enhancing User Experiences With
Advanced Reporting Features

Understanding Bookmark Capture States
Configuring and Formatting Buttons
Applying Measure Based Formatting
Implementing Report Tooltips






Applying Measure Based Formatting

Conditional Formatting

Rows
Promotion Name v X
Start Year N X

€

Remove field
Rename
Move

Move to

Conditional formatting

Show value as

New quick measure

e )

 Conditional formatting can be applied to calculated
measures in either the table or matrix visuals

>

>

» Background color
Font color

v Data bars
lcons
Web URL

Page Title & Geo

Page Views

Hawvens Consulting

Files & Templates — Hav.

Blog / Media — Havens ...
Blog Posts — Havens Co...
Power Bl Vs. Excel — Hav...
Havens Consulting — Se...
About Us — Havens Con...
What Is Power BI? — Hav...

Creating a Slicer Pop-Qut...

Zrnnla Analiticc Ranort

3,464

2,695
2,367
1,403
1,226
855
800

TJoR

Unique Views Searches Bounce Rate a
546 @  47.6%
225 @ 728%
35 @  732%
2,05 33 63.6%
2,202 1540 @ 91.2%
)34 0 @ 379%
,049 455 @  47.1%
723 241 57.5%
9 @ 80.1%
710 on R an QoL




Total | 29,936 24,836 4,512 70.0%



Applying Measure Based Formatting

Conditional Formatting

= = &  Conditional formatting can be applied to calculated
po— measures in either the table or matrix visuals

N e « Settings can be accessed:
* In the Fields well of the Visualizations pane’
« From the sub-menu under the Formatting pane

Sales Quantity

Background color

off O—

Font color

off O—

Data bars

On —@

Advanced controls




Ilcons

off O—



Applying Measure Based Formatting

Conditional Formatting » Background and Font Colors

» Background and font color share
the Same format by Settings Backaround color - Sales

» Formatting logic can be based on: | == ] [

* Color scale
« Applies a gradient between min and max Minimur

* Min/Max can be set to lowest value or fixed
absolute value

« Diverging enables a third middle color






Applying Measure Based Formatting

Conditional Formatting » Background and Font Colors

» Background and font color share

the same format by settings ———
< 4 F ooooo by ) .Applyw
» Formatting logic can be based on: =
Based on field
* Rules
« Applies colors based on one or more value e ﬁ -
ranges, each with a set color o e — e e T
 Each value range starts with: e isgreserhanorsqoito v [66 | | . ]

« An If value condition
* An and value condition
 And a color






Applying Measure Based Formatting

Conditional Formatting » Background and Font Colors

» Background and font color share
the same format by settings

» Formatting logic can be based on: ...

- Field value it Values only
* Field value
Based on field

« Applies colors by using a calculated measure o er——
or a column that specifics a color — either
using a text value or a hex code

« Custom logic can be created inside a
calculated measure to apply the desired color

! garn more

Field value formatting will be outside



the scope of this presentation



Applying Measure Based Formatting

Conditional Formatting = Data Bars

 Data bars can be set to lowest value or
fixed absolute value

- Other data Bar properties:
» Positive/negative bar (color) e e

Data bars

Format cells with bars based on their values.

e AXIS (CO(OI") tovest e 7] [ighstaue
» Bar direction i
« Show bar only — hides the value

Positive bar Bar direction

Left to right
Negative bar Axis

OK






Applying Measure Based Formatting

Conditional Formatting = Icons

» Icon sets in Power Bl are very similar
to the ones found in Excel

Icons - Sales

» Formatting logic can be based on
Rules or Field Value

» By default, icon rules will apply: ' i o
* Red diamond to the lower 33%
+ Yellow triangle to the middle 33% e T T Rresessecd ...
 Green circle to the upper 33% L o e

. . . Ol B L D ¢ ]
» Custom icon sets can be imported in @x kK Kk V= ad

fll ol o] ol ol ol ol B= BB

Power Bl Desktop iy dddadddd=a,



Nag icon




Applying Measure Based Formatting

Conditional Formatting = Web URL

 Web URLs can be applied to fields as  weur-soe
active links if there is a column or ot

uuuuuuuuuu

measure that contains a website URL s

» Formatting logic is based on Field
value

. When this formatting iS applied to a Salecsolj:rjns Sales YoY Sales YoY TopSelProdJct A
field — each row is an active link to a -

. United States | $21,814,465  $5,470,851 33% A. Datum Slim Di...
We b S Ite Regular $11,932,740 $2,911,538 ' 32% NT Wireless Transm...
Deluxe $7,598,807 $1,981,601 L 35% A. Datum Super-zo..
Economy $2,282,918 $577,712 « 34% A. Datum Slim Digit...
Canada $5,313,337 . $1,196,486 29% Contoso Wireless ...
Raatilar ¢ Q85 745 <700 1725 “-#ﬂi? 21% A Datum Bridaoe M




Deluxe = . $358,646 * 27% Contoso Wireless N...




Applying Measure Based Formatting

Conditional Formatting = Subtotals and Totals

» Conditional formatting can also be

Format by Apply to

applied to the subtotals and totals in -
matrix tables

+ New rule
5
* Thresholds and ranger: must be set
manually when applied
Sales Details
Country Sales YoY Sales YoY Top Selling Product A
Sales %
v
United States | $21,814,465 $5,470,851 33% A.Datum Slim Di...
Regular $11,932,740 §0971538 J» 32% NT Wireless Transm. .
Deluxe $7,598,807 $1,981,601 35% A.Datum Super-zo...
Economy $2,282.918 $577.712 34% A. Datum Slim Digit. .
Canada $5.313,337 - $1,196,486 “» 29% Contoso Wireless ...
Regular 42,985,745 $700,125 & 31% A Datum Bridge Di...




1: Only numbers be applied — not percentages ‘ Deluxe

|= W 358646 b 27% Contoso Wireless N..




Applying Measure Based Formatting

Conditional Formatting = Other Applications

.  o—e | ¢ Measure Based Formatting can also be applied to
. other visual and object attributes

Amount by Date || fx » Attributes where this formatting can be applied are indicated
with an fx button next to it

Word wrap . . .
o —® « Two primary types of formatting are available:
» Color - Logic is based on: Color scale, Rules, or Field value
Font color . . "
* Text — Logici n: Field value’
=l ext — Logic Is based on: Field value
Background color
L]~ K&

1: Creates a dynamic text string that can be



Changed auring retresh or Tilter selection



%E Demonstration
Three

Applying Measure Based Formatting

Exercise 1 — Applying Background/Font Color Formatting
Exercise 2 — Applying Data Bar Formatting

Exercise 3 — Applying Web URL Formatting

Exercise 4 — Understanding Other Applications













References

» Use Conditional Formatting in Tables
* https://docs.microsoft.com/power-bi/desktop-conditional-table-formatting

* Tips and Tricks for Formatting in Power B
* https://docs.microsoft.com/power-bi/visuals/service-tips-and-tricks-for-color-
formatting
» HC Video Playlist — Conditional Formatting
* https://www.youtube.com/playlist?list=PLzNI9cpDwboCYtf0aftU8d AyXfdWpQb
J
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Implementing Report Tooltips

Tooltips Introduction

* Tooltips are an elegant way of providing more contextual information
and detail to data points on a visual

» By default, tooltips displays the S e e P

data point's value and category! ..

@® Arabic

* Fields may be added to the Armenian

Country United States \:‘
I

tooltips well to provide additional |**= 'AEEEEE

Page Views 11,195

. Catalan

data pOlntS Chinese
Croatian

® Czech
Danish

@ Dutch




1: looltips can also be disabled Tor specitiC visuals v s © 2019 Microsaft Gorporation Terms




Implementing Report Tooltips

Tooltips = Report Tooltips

» Additionally, report tooltip pages can
be created to display visuals as a tooltip

» Tooltip pages:
 Can be set to any height or width
* Can include any visual or object

* Cannot be interacted with inside
the tooltip?

1: Elements such as slicers, hierarchy controls,

Page Views by Locat

Language
@ Arabic
Armenian
@ Bulgarian
Catalan
Chinese
Croatian
® Czech
Danish

@® Dutch

[ a)

NOR]

4

4,740 Page Views by Day and Time (1)

12 AM
1AM
2AM
3AM
4AM
5 AM
6 AM
7AM
8 AM
9AM I
10 AR

11 AM
12 PM
1PM
2PM
3PM
4PM
5 PM

6 PM
7PM
8 PM
9 PM
10 PM
11 PM

)

ASIA

&

¢ &6

g
O

@ @@

(56.-_% AMERICA V@@@ :

C{}S’Rﬁ




(JHHTHI'OUQH, etC CannOt De C“CKed v L) © 2019 Microsaft Corporation  Terms




Implementing Report Tooltips

Tooltips = Report Tooltips » Configuration

 Configurations for report tooltips are accessed in =
the format pane for the report page’

» Report tooltip settings:

* Tooltip (toggle) — enables this page to be used as a
tooltip by other page visuals Name

Website Summary

_______

/Q Search

~ Page information

ey Tooltip
On —4

Q&A

1: Page formatting is only accessible if Off C



there is not an active page visual selected



Implementing Report Tooltips

Tooltips = Report Tooltips » Configuration

» Configurations for report tooltips are accessed in =
the format pane for the report page’

» Report tooltip settings:
* Tooltip (toggle) — enables this page to be used as a

/Q Search

 Page information

tooltip by other page visuals A Page size
* Page size — configuration of the pixel size and width, Type
common configurations include: Tooltip
« Tooltip — 320 x 240 pixels — | [169
 Custom — User defined pixel width and height 48
Page sizes =-= Letter
Tooltip

1: Page formatting is only accessible if N Custom




there is not an active page visual selected




Implementing Report Tooltips

Tooltips = Visual Header Tooltips

* Tooltips can also be created
inside the visual header to
display information relevant to  [wesicvie by p——

: Language with the ability to drill between Visitor Continent.
a VI S U a | ® (Not Set) Country, State/Region, or City

® Arabic

* Visual Header Tooltips: A

 Can be configured to be either a ® Bulgarian
standard Tooltip or a Report Tooltip  *

® Chinese

e Can be customized for each visual Croatian

Czech
® Danish

Dutch

English






Implementing Report Tooltips

Tooltips = Visual Header Tooltips = Configuration

 Configurations for visual header report tooltips = 7 Q
are accessed in the visual header for the visual o

* Visual header tooltip settings: v B
* Visual header tooltip icon (toggle) — enables the o s O

tooltip icon and toggles visibility of the configuration

menu for the visual header tooltip v Background  Off O—

v Lock aspect  Off Q—
v Border off O—
v Tooltip On —@

Visual header tooltip toggle = Visual header On —@

r'\:.-..-.|-n = \lfL\l‘\Iﬂ 'I-ﬂﬂﬂlﬂ =, A S b, B i SRSt B ey Y Y



LISPidys WIICTHT LOYYIC 15 VI | =====ggF ~ Visual neaaer tooiip



Implementing Report Tooltips

Tooltips = Visual Header Tooltips = Configuration

 Configurations for visual header report tooltips
are accessed in the visual header for the visual

* Visual header tooltip settings:

» Visual header tooltip icon (toggle) — enables the
tooltip icon and toggles visibility of the configuration
menu for the visual header tooltip

* Visual header tooltip (menu) — contains all
configuration options, such as:
* Report Page — which page to assign to tooltip (if desired)

« Tooltip Text — text to display inside tooltip
* Up to 250 characters

e EAnrmmnttinmn Anntinnc

\ Visual header tooltip

Report page

q Tooltip text
his lir
"




AT FTTIvALLLT ly UI.ILI.UI 1.2

» E.g. font size, color, background, transparency



%E Demonstration
Four

Implementing Report Tooltips

* Exercise 1 — Configuring a Report Tooltip Page
» Exercise 2 — Adding Report Tooltips to Visuals
» Exercise 3 — Enabling Visual Header Tooltips












Recommended Practices

* Consider the audience and their needs

 Just because a feature exists does not mean it has to be used in a
report

 Use conditional formatting to draw attention to important data
* Leverage tooltips to provide additional relevant information to visuals

» Configure bookmarks to reduce the number of mouse clicks and
mouse travel for users — enabling a more intuitive report experience






References

» Create Tooltips Based on Report Pages
e https://docs.microsoft.com/power-bi/desktop-tooltips

» Extend Visuals with Report Page Tooltips
* https://docs.microsoft.com/power-bi/guidance/report-page-tooltips

» HC Video Playlist — Tooltips
e https://www.youtube.com/playlist?list=PLzN99¢cpDwb60AU 0U3cZhLDDBhVm6M

|5Pv






Online Resources

Presentation PDF

= http://www.havensconsulting.net/speaking-events

Consulting Services

= http://www.havensconsulting.net/consulting-services

0ol Files & Templates

= http://www.havensconsulting.net/files-and-templates

30% Discount Code

=  SQLSAT1000
YouTube Channel

. - Microsoft*

| Most Valuable
Professional

= https://www.youtube.com/c/HavensConsulting

LinkedIn Page



https:// www.linkedin.com/in/reidhavens
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Need help with Power BI?

Ask for help!
Your local Microsoft Partners and consultants are here to help

Flexible professional services to help you or your team:
Solve technical challenges
Accomplish redundant tasks
Move faster on projects or your backlog

Contact: info@marguam.com







Want to provide feedback on the presentation?

https://www.surveymonkey.com/r/PSKT9VC
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